Kategorie: Svět IT

Cisco - Nastavení router "on the stick" v Paket Traceru

Cisco - Nastavení router "on the stick" v Paket Traceru

Router on the stick se používá pokud máme na switchi nastavené VLANy a chceme, aby si uživatlé z různých VLAN byly schopni mezi sebou posílat zprávy. Jelikož switch nemá žádné prostředky k tomu, aby byl schopen zprávy posílat mezi VLANy, musíme použít zařízení, které pracuje na L3 vrstvě, v tomto případě router. Uživatel pak pošle zprávu z dané VLANy na router a ten ji pošle zpátky do VLANy jiné.

Budu vycházet z topologie na obrázku níže. Router a switch jsou propojeny TRUNKem. Každý ke switchi připojený počítač je v jiné VLANě.

 

 

 

 

 

 

 

 

 

 

 

 

 

Konfigurace koncových zařízení (počítačů)

Na počítačích nastavíme jejích IP adresy, masky a výchozí brány:

 

PC1:

IP adresa: 192.168.10.10

Maska: 255.255.255.0

Výchozí brána: 192.168.10.1

PC2:

IP adresa: 192.168.20.20

Maska: 255.255.255.0

Výchozí brána: 192.168.20.1

PC3:

IP adresa: 192.168.30.30

Maska: 255.255.255.0

Výchozí brána: 192.168.30.1

Konfigurace VLAN a TRUNKu na switchi

Konfigurace VLAN:

Switch>enable

Switch#configure termina

Switch(config)#vlan 10

Switch(config-vlan)#name vlan10

Switch(config-vlan)#exit

Switch(config)#vlan 20

Switch(config-vlan)#name vlan20

Switch(config-vlan)#exit

Switch(config)#vlan 30

Switch(config-vlan)#name vlan30

Switch(config-vlan)#exit

Switch(config)#interface fastEthernet 0/2

Switch(config-if)#switchport mode access

Switch(config-if)#switchport access vlan 10

Switch(config-if)#exit

Switch(config)#interface fastEthernet 0/3

Switch(config-if)#switchport mode access

Switch(config-if)#switchport access vlan 20

Switch(config-if)#exit

Switch(config)#interface fastEthernet 0/4

Switch(config-if)#switchport mode access

Switch(config-if)#switchport access vlan 30

Switch(config-if)#exit

 

Konfigurace TRUNKu:

 

Switch(config)#interface fastEthernet 0/24

Switch(config-if)#switchport mode trunk

Switch(config-if)#switchport trunk allowed vlan 10,20,30

Switch(config-if)#exit

 

Konfigurace subinterface na routeru

Tak a teď ta podstatná část, konfigurace routeru:

 

Router>enable

Router#configure terminal

Router(config)#interface fastEthernet 0/1.10 //vytvoření subinterface

Router(config-subif)#encapsulation dot1Q 10  //přiřazení čísla VLANy danému sub-portu

Router(config-subif)#ip address 192.168.10.1 255.255.255.0

Router(config-subif)#no shutdown 

Router(config-subif)#exit

Router(config)#interface fastEthernet 0/1.20 //vytvoření subinterface

Router(config-subif)#encapsulation dot1Q 20  //přiřazení čísla VLANy danému sub-portu

Router(config-subif)#ip address 192.168.20.1 255.255.255.0

Router(config-subif)#no shutdown 

Router(config-subif)#exit

Router(config)#interface fastEthernet 0/1.30 //vytvoření subinterface

Router(config-subif)#encapsulation dot1Q 30  //přiřazení čísla VLANy danému sub-portu

Router(config-subif)#ip address 192.168.30.1 255.255.255.0

Router(config-subif)#no shutdown 

Router(config-subif)#exit

Router(config)#interface fastEthernet 0/1

Router(config-if)#no shutdown 

 

Konfigurace subinterface na routru

Subinterface vytvoříme tak, že vybereme daný port ke kterému je připojený switch na kterém jsou nakonfigurované VLANy. Výsledný interface vypadá pak takto: interface_id.Subinterface_id (interface fastEthernet 0/1.10). Na daném subinterfacu musíme potom přiřadit VLANu, která se bude propagovat příkazem: encapsulation dot1Q vlan_id (encapsulation dot1Q 10). Poté už jen nastavíme IP adresu a masku jako u běžného interfacu a příkazem no shutdown spustíme. Musíme nahodit i samotný interface bez subinterfacu.

 

Konfiguraci si ověříme příkazem ping z počítače jedné VLANy na počítač z jiné VLANy. Poprvé ping neprojde a bude vypsána hláška Request timed out. Ping zopakujeme a poté už by mělo vše správně fungovat.

Ping z počítače 192.168.20.20 na adresy 192.168.10.10 a 192.168.30.30 proběhl v pořádku.

 

 

Komentáře rss


Nebyly přidány žádné komentáře.

„Nikdy jsem nedopustil, aby škola stála v cestě mému vzdělání.“ Mark Twain